USPS Label Creation Errors

Incident Report for Flowspace

Resolved

Flowspace has resolved the issue. All affected orders should be able to proceed with label purchase now.
Posted Oct 08, 2024 - 12:22 PDT

Monitoring

Flowspace has identified problems purchasing USPS labels which are causing fulfillment batches to fail to complete. We have identified the cause with a downstream provider and are working around the problem. Full operational service will be restored shortly.
Posted Oct 08, 2024 - 11:52 PDT
This incident affected: Flowspace WMS (Parcel Labeling).