Canada Post Carrier Outage

Incident Report for Flowspace

Resolved

Our upstream provider indicates that this incident has been resolved
Posted Feb 27, 2026 - 11:57 PST

Investigating

Flowspace is currently unable to purchase labels for Canada Post. We will provide updates as we receive them.
Posted Feb 27, 2026 - 10:22 PST
This incident affected: Flowspace WMS (Parcel Labeling).