app.flow.space is currently down

Incident Report for Flowspace

Resolved

There was an issue with our infrastructure provider. We have moved to a fallback provider and access has been restored.
Posted Jun 10, 2020 - 11:21 PDT

Investigating

We are currently investigating this issue.
Posted Jun 10, 2020 - 11:18 PDT