Label Purchasing Issue
Incident Report for Flowspace
Resolved
This incident has been resolved.
Posted May 04, 2023 - 14:46 PDT
Monitoring
The upstream provider has implemented a fix and is now monitoring.
Posted May 04, 2023 - 13:49 PDT
Investigating
Flowspace is experiencing technical issues purchasing labels from an upstream provider. We are working with the provider to resolve the issue.
Posted May 04, 2023 - 13:41 PDT