Degraded FedEx Performance

Incident Report for Flowspace

Resolved

FedEx API performance has returned to normal performance.
Posted Mar 19, 2025 - 13:18 PDT

Monitoring

The incident rate is slowing, we are continuing to monitor.
Posted Mar 19, 2025 - 12:18 PDT

Investigating

The FedEx API is currently in a degraded state, disrupting Flowspace's ability to purchase labels from the carrier.

Message from FedEx:
We are experiencing an issue that started around 12:12pm CT today that is causing certain functions to operate slower than usual or be temporarily unavailable. Our IT teams are working diligently to identify and resolve the problem. We regret any inconvenience this have caused.
Posted Mar 19, 2025 - 11:35 PDT
This incident affected: Flowspace WMS (Parcel Labeling).