Flowspace is experiencing connectivity interruptions

Incident Report for Flowspace

Resolved

Service to Flowspace has been restored. We will continue to monitor our upstream provider for any recurrence of the issues that impacted us today.
Posted Nov 18, 2025 - 07:07 PST

Update

We are seeing improvements in connectivity, but continue to monitor the situation.
Posted Nov 18, 2025 - 05:28 PST

Update

Flowspace continues to experience interruptions in service.
Posted Nov 18, 2025 - 04:57 PST

Monitoring

Our downstream provider has reported that services are recovering. We continue to monitor the situation.
https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 04:27 PST

Investigating

A downstream provider is experiencing unspecified issues in its global network that is impacting Flowspace by causing interruptions in service. We continue to monitor this situation and will provide updates as the situation develops.
The downstream issue impacting Flowspace can be monitored directly here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7.
Posted Nov 18, 2025 - 04:07 PST
This incident affected: Merchant Suite (Orders, Inventory, Shopping Cart Integrations), Flowspace WMS (Freight Management, Parcel Labeling, Printing, Mobile Picking, Order Receiving & Putaway, Batch Processing, Inventory Movements), and Reporting, Billing, Flowspace API.