app.flow.space is currently down
Incident Report for Flowspace
Resolved
https://app.flow.space is now back online. We will continue to monitor the situation at our hosting provider to ensure our site stays online.
Posted Apr 15, 2020 - 13:40 PDT
Update
You can access our app through https://flowspaceapp.com/ until our hosting provider has resolved the issue.
Posted Apr 15, 2020 - 10:22 PDT
Investigating
Our hosting provider is currently experiencing an outage, we are currently investigating a solution.
Posted Apr 15, 2020 - 09:47 PDT